RB Text Editor will not save changes to file needing root access

Anonymous shared this problem 5 years ago
Unknown

Tried to edit a preferences file below the /data/data/..package../shared_prefs folder. Obviously used root access to navigate using Toolbox Pro. Then long clicked and chose Open With. Then chose "RB Text Editor". Opened the file, made a change and clicked the save icon. The toast said it worked, but when I closed and re-opened, the change was not saved. Long clicked on the file and change the permissions to grant read/write to everyone and then tried again and the save worked. Looks like it's not using su to perform the save operation if it had to use su to open the file in the first place.

Comments (2)

photo
187

Hey,

Are you using Android 4.3 also, what ROM are you using?

photo
191

Hi. I'm using an htc one x running 4.0.4 with an Android Revolution HD 9 rom. It's a bit old, but it's stable and no problems with normal apps or any root apps. It's also using the latest busybox, if that helps. I can edit the same file fine on a Nexus 7 2013 running latest stock and the same version of Rom Toolbox Pro.